NCTDXTRANSFORM2Lib

NCTAudioStudio2 ActiveX DLLs
NCTDXTransform2 ActiveX DLL

Version 2.2

NCTDXTransform2 ActiveX DLL is intended for applying preinstalled DirectX filters to the audio file or audio data array.

NCTDXTransform2 is a part of the NCTAudioStudio2 package.

Send Feedback on the NCTDXTransform2 documentation.
NCTDXTransform2 was developed by NCT company http://www.nctsoft.com


DXTransform2 methods

DXTransform2 methods

Method | Description
CancelTransform | Cancels the process of of audio data array transformation.
GetFilterName | Gets the name of the preinstalled DirectX filter specified by Index value.
GetFiltersCount | Gets the number of preinstalled DirectX filters.
Register | Enters user name and registration password to disable About window.
TransformArray | Applies an Index filter to the existing audio data array.
TransformFile | Applies an Index filter to the existing audio file.

Send Feedback on the NCTDXTransform2 documentation.
NCTDXTransform2 was developed by NCT Company Ltd. http://www.nctsoft.com


CancelTransform method

CancelTransform method (DXTransform2 object)

Cancels the process of of audio data array transformation.

Syntax

object.CancelTransform()

The CancelTransform method syntax has these parts:

Part | Type | Description
object | DXTransform2 | An expression evaluating to an object.

Remarks:

Before applying this method the transformation process must be started by one of the following methods: TransformArray, TransformFile.

Example:

' VB sample where DX2 is an DXTransform2 object.
If DX2.GetFiltersCount > 0 Then
MsgBox "The " & DX2.GetFilterName(DX2.GetFiltersCount) & "filter applies to the audio file."
DX2.TransformFile "C:\track01.wma", "C:\track01_filter.wma", DX2.GetFiltersCount
...
DX2.CancelTransform
End If

See Also:

Applies to: DXTransform2


GetFilterName method

GetFilterName method (DXTransform2 object)

Gets the name of the preinstalled DirectX filter specified by Index value.

Return Type

A String value.

Syntax

FilterName = bject.GetFilterName(Index As Long)

The GetFilterName method syntax has these parts:

Part | Type | Description
object | DXTransform2 | An expression evaluating to an object.
Index | Long | Value that specified the filter. Varies from 1 to FiltersCount returned by GetFiltersCount method.
FilterName | String | The name of the preinstalled DirectX filter.

Example:

' VB sample where DX2 is an DXTransform2 object.
For i = 0 To DX2.GetFiltersCount - 1
List1.AddItem DX2.GetFilterName(i)
Next i
If List1.ListCount > 0 Then List1.ListIndex = 0

See Also:

GetFiltersCount

Applies to: DXTransform2


GetFiltersCount method

GetFiltersCount method (DXTransform2 object)

Gets the number of preinstalled DirectX filters.

Return Type

An Integer value.

Syntax

FiltersCount = object.GetFiltersCount()

The GetFiltersCount method syntax has these parts:

Part | Type | Description
object | DXTransform2 | An expression evaluating to an object.
FiltersCount | Integer | The number of preinstalled DirectX filters.

Example:

' VB sample where DX2 is an DXTransform2 object.
For i = 0 To DX2.GetFiltersCount - 1
List1.AddItem DX2.GetFilterName(i)
Next i
If List1.ListCount > 0 Then List1.ListIndex = 0

See Also:

GetFilterName

Applies to: DXTransform2


Register method

Register method (DXTransform2 object)

Enters user name and registration password to disable About window.

Syntax

object.Register(bstrUser As String, bstrPassword As String)

The Register method syntax has these parts:

Part | Type | Description
object | DXTransform2 | An expression evaluating to an object.
bstrUser | String | User name. You get a registration user name after the registration.
bstrPassword | String | Password string. You get a registration password after the registration.

Example:

' VB sample where DX2 is an DXTransform2 object.
DX2.Register "XXX", "XXX"

See Also:

Applies to: DXTransform2


TransformArray method

TransformArray method (DXTransform2 object)

Applies an Index filter to the existing audio data array.

Return Type

A Integer() value.

Syntax

OutputArray = object.TransformArray(InpArray As unknown - type, ArrayChannels As ChannelsConstants, ArrayFrequency As FrequencyConstants, FilterIndex As Integer)

The TransformArray method syntax has these parts:

Part | Type | Description
object | DXTransform2 | An expression evaluating to an object.
InpArray | Integer() | An audio data array.
ArrayChannels | ChannelsConstants | The number of channels in the audio data array that will be transformed.
ArrayFrequency | FrequencyConstants | Frequency is in hertz in the audio data array that will be transformed.
FilterIndex | Integer | Value that specified the preinstalled DirectX filter.
OutputArray | Integer() | Transformed audio data array.

Remarks:

The GetFilterName method returns the name (or description) of the filter index.

Example:

' VB sample where DX2 is an DXTransform2 object.
' The Input() array can be created using NCTAudioFile2.dll
Dim Output() As Integer
If DX2.GetFiltersCount > 0 Then
MsgBox "The " & DX2.GetFilterName(DX2.GetFiltersCount) & "filter applies to the audio file."
Output() = DX2.TransformArray Input(), STEREO, FQ_44_KHZ, DX2.GetFiltersCount
End If

See Also:

TransformFile

Applies to: DXTransform2


TransformFile method

TransformFile method (DXTransform2 object)

Applies an Index filter to the existing audio file.

Syntax

object.TransformFile(InFileName As String, OutFileName As String, FilterIndex As Integer)

The TransformFile method syntax has these parts:

Part | Type | Description
object | DXTransform2 | An expression evaluating to an object.
InFileName | String | The path to the input file.
OutFileName | String | The path to the output file.
FilterIndex | Integer | Value which specified preinstalled DirectX filter.

Remarks:

The GetFilterName method returns the name (or description) of the filter index.

Example:

' VB sample where DX2 is an DXTransform2 object.
If DX2.GetFiltersCount > 0 Then
MsgBox "The " & DX2.GetFilterName(DX2.GetFiltersCount) & "filter applies to the audio file."
DX2.TransformFile "C:\track01.wma", "C:\track01_filter.wma", DX2.GetFiltersCount
End If

See Also:

TransformArray

Applies to: DXTransform2


DXTransform2 events

DXTransform2 events

Event | Description
Complete | Occurs when the transformation process is completed.
Progress | Occurs during the transformation process.

Send Feedback on the NCTDXTransform2 documentation.
NCTDXTransform2 was developed by NCT Company Ltd. http://www.nctsoft.com


Complete event

Complete event (DXTransform2 object)

Occurs when the transformation process is completed.

Syntax

Sub object_Complete()

Example:

' VB sample where DX2 is an DXTransform2 object.
Private Sub DX2_Complete()
MsgBox "Transformation completed"
End Sub

See Also:

Progress

Applies to: DXTransform2


Progress event

Progress event (DXTransform2 object)

Occurs during the transformation process.

Syntax

Sub object_Progress(Percent As Integer)

The Progress event syntax has these named arguments:

Part | Type | Description
Percent | Integer | Execution percent.

Example:

' VB sample where DX2 is an DXTransform2 object.
Private Sub DX2_Progress(ByVal Percent As Integer)
'You can insert your code there
DoEvents
End Sub

See Also:

Complete

Applies to: DXTransform2


NCTDXTransform2 constants

NCTDXTransform2 constants

Constants | Description
ChannelsConstants | These are the constants for the TransformArray method.
FrequencyConstants | These are the constants for the TransformArray method.

Send Feedback on the NCTDXTransform2 documentation.
NCTDXTransform2 was developed by NCT Company Ltd. http://www.nctsoft.com


ChannelsConstants enumeration

ChannelsConstants enumeration

These are the constants for the TransformArray method.

Members

Part | Value | Description
MONO | 1 | Mono data uses one channel.
STEREO | 2 | Stereo data uses two channels.


FrequencyConstants enumeration

FrequencyConstants enumeration

These are the constants for the TransformArray method.

Members

Part | Value | Description
FQ_96_KHZ | 96000 | 96000 hertz.
FQ_88_KHZ | 88200 | 88200 hertz.
FQ_48_KHZ | 48000 | 48000 hertz.
FQ_44_KHZ | 44100 | 44100 hertz.
FQ_32_KHZ | 32000 | 32000 hertz.
FQ_24_KHZ | 24000 | 24000 hertz.
FQ_22_KHZ | 22050 | 22050 hertz.
FQ_16_KHZ | 16000 | 16000 hertz.
FQ_12_KHZ | 12000 | 12000 hertz.
FQ_11_KHZ | 11025 | 11025 hertz.
FQ_8_KHZ | 8000 | 8000 hertz.
FQ_6_KHZ | 6000 | 6000 hertz.


DXTransform2

DXTransform2 object

NCTDXTransform2 ActiveX DLL is intended for applying preinstalled DirectX filters to the audio file or audio data array.


NCTDXTRANSFORM2Lib

NCTAudioStudio2 ActiveX DLLs

Version 2.2

NCTDXTransform2 ActiveX DLL is intended for applying preinstalled DirectX filters to the audio file or audio data array.

NCTDXTransform2 is a part of the NCTAudioStudio2 package.